[Gambas-user] 3.15 RPM packager creates SPEC file with unwanted dependencies

Benoît Minisini g4mba5 at gmail.com
Wed Jul 29 14:40:56 CEST 2020

Le 25/07/2020 à 12:34, Bruce a écrit :
> My confusion lies in the supposed relationship between the Gambas 
> project version and the package required version.If I have ComponentA at 
> project version 0.1.6 and ComponentB at version 16.4.9998 how do I tell 
> the IDE packager to create a package version 3.15?
> Further, if ProjectXYZ has a dependency on ComponentA at a minimum 
> project version of 0.1.6 and won't work with 0.1.5 then the IDE packager 
> would say that "you need to have ComponentA.3.15" whether or not my 
> ComponetA-3.15 package is currently containing ComponentA projecct 
> version  0.1.6  or some prior version?
> Worse, if ComponentB project version 16.4.9998 and my package is 
> ComponentB-3.15 but ProjectXYZ depends on componentB project version 
> 16.4.9998 and nothing earlier will do. Then how can I tell that to the
> Rotten Package Manager?
> regards
> Bruce
> On 25/7/20 6:30 pm, Benoît Minisini wrote:
>> A component, whether it is local or part of Gambas sources, must have 
>> the same version number as the Gambas version it is compatible with.
>> As I often say, a Gambas component is for Gambas like a Linux driver 
>> is for Linux. They follow the same version.
>> Regards,

As I said, the version of a Gambas component *must be* the same as the 
Gambas version it is done with. Because a Gambas component is supposed 
to be part of the language.

If you want a component (in a generic sense) whose version is completely 
independent, then you must write a Gambas library.


Benoît Minisini

More information about the User mailing list