[Gambas-user] 3.15 RPM packager creates SPEC file with unwanted dependencies

Brian G brian at westwoodsvcs.com
Wed Jul 29 01:47:17 CEST 2020

Can your components, be libraries instead?

Thank You
Brian G

----- Original Message -----
From: "Bruce" <adamnt42 at gmail.com>
To: "Gambas mailing list" <user at lists.gambas-basic.org>
Sent: Saturday, July 25, 2020 3:34:54 AM
Subject: Re: [Gambas-user] 3.15 RPM packager creates SPEC file with unwanted dependencies

My confusion lies in the supposed relationship between the Gambas 
project version and the package required version.If I have ComponentA at 
project version 0.1.6 and ComponentB at version 16.4.9998 how do I tell 
the IDE packager to create a package version 3.15?

Further, if ProjectXYZ has a dependency on ComponentA at a minimum 
project version of 0.1.6 and won't work with 0.1.5 then the IDE packager 
would say that "you need to have ComponentA.3.15" whether or not my 
ComponetA-3.15 package is currently containing ComponentA projecct 
version  0.1.6  or some prior version?

Worse, if ComponentB project version 16.4.9998 and my package is 
ComponentB-3.15 but ProjectXYZ depends on componentB project version 
16.4.9998 and nothing earlier will do. Then how can I tell that to the
Rotten Package Manager?


On 25/7/20 6:30 pm, Benoît Minisini wrote:
> A component, whether it is local or part of Gambas sources, must have 
> the same version number as the Gambas version it is compatible with.
> As I often say, a Gambas component is for Gambas like a Linux driver is 
> for Linux. They follow the same version.
> Regards,

----[ http://gambaswiki.org/wiki/doc/netiquette ]----

More information about the User mailing list