[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Limited translation options


On Saturday, October 17th, 2026 at 13:35, Benoît Minisini <benoit.minisini@xxxxxxxxxxxxxxxx> wrote:

> Le 16/10/2026 à 20:33, gbWilly a écrit :
> > If I look at the code for MyLanguage.module and Language.Class they seem to serve a different goal.
> > I didn't go serach how they are integrated into the rest, just purely comparing both.
> >
> > So, with the Language.class 'cleaned up and sorted out', do you want to sync it with the MyLanguage.module?
> > Or are you first going to investigate why the MyLanguage.module was created in the first place.
> >
> > Just let me know and I'll make it all sync with each other if needed.
> >
> >
> > gbWilly
> >
> > ...there is always a Catch if things go wrong!
> >
> > P.S. My excuses if my logs weren't correct..
> 
> Yes. It's just a matter of avoiding duplicated code between
> 'Language.class' and 'MyLanguage.class'. But 'MyLanguage' has
> IDE-specific methods that must be kept.
> 
> So, concretely:
> 
> 1) Remove the 'Name' and 'EnglishName' private variables of
> 'MyLanguage', and replace them by calls to 'Language'.
> 
> 2) Replace the 'Find()' method by 'Language.Find()', or call
> 'Language.Find()' from 'Find()' if you don't want to touche other parts
> of the source code. The second argument of 'Find()' will be removed as
> it is used by 'MyLanguage' only.
> 

What I meant with bringing it in sync is move the languages added to Language.class over to MyLanguage.module in its current state. and adapt them to work there.
What you describe in 1) and 2) is an entire different thing as it means throwing what I wanted to sync out of the MyLanguage.module, which makes a lot of sense.

I had a look at it and tried to wrap my head around it. I think don't know enough of the ins and outs of how all hangs together in the IDE.
There are multiple calls to parts of MyLanguage.module made all over. And I think more changes that what you suggest above are needed to make it all come together.
I'm lacking the bird-eye view to make that happen, so, I leave this up to the grandmaster of Gambas and I will definitely study the resulting code.

gbWilly


Follow-Ups:
Re: Limited translation optionsgbWilly <gbWilly@xxxxxxxxxxxxxx>
References:
Limited translation optionsgbWilly <gbWilly@xxxxxxxxxxxxxx>
Re: Limited translation optionsBenoît Minisini <benoit.minisini@xxxxxxxxxxxxxxxx>
Re: Limited translation optionsgbWilly <gbWilly@xxxxxxxxxxxxxx>
Re: Limited translation optionsBenoît Minisini <benoit.minisini@xxxxxxxxxxxxxxxx>
Re: Limited translation optionsgbWilly <gbWilly@xxxxxxxxxxxxxx>
Re: Limited translation optionsgbWilly <gbWilly@xxxxxxxxxxxxxx>
Re: Limited translation optionsgbWilly <gbWilly@xxxxxxxxxxxxxx>
Re: Limited translation optionsBenoît Minisini <benoit.minisini@xxxxxxxxxxxxxxxx>
Re: Limited translation optionsgbWilly <gbWilly@xxxxxxxxxxxxxx>
Re: Limited translation optionsBenoît Minisini <benoit.minisini@xxxxxxxxxxxxxxxx>