<div dir="ltr"><div dir="ltr"><br></div><div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">
You can't rely on your source code being viewed in an IDE.  For instance, when you post it to a site, email it to someone, etc.<br></blockquote><div>... <br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">

The same is true for syntax coloring, nice, but you shouldn't rely on it for readability.<br></blockquote><div></div><div><div><br></div><div>Of course you should rely on that. There is 
absolutely no good reason to separate any RAD language from its IDE 
(or compatible IDE).</div>Only very trivial code is ever viewed 
outside of IDE. And even then the source code should be posted as 
archive, if it is meant to be executed.</div><div> </div><div><br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">

This FMain.class is a test cradle for the objects.  Set up to show that you can make many of the objects, but you only need one to test if it works.<br></blockquote><div><br></div><div>Very bad programming habit. These should be in separated unit tests or they shouldn't exist at all.<br></div><div><br></div><div> </div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">

I explained in my lengthy reply where the prefixes came from.<br></blockquote><div><br></div><div>Exactly.<br></div><div> </div><div> </div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"> ... it also makes your code more similar to natural language.  You can't see a benefit in that?<br></blockquote><div><br></div><div>I don't see the benefit in your convention. However long descriptive variable names generally do that, but sometimes it is not beneficial for the readability (in complex lines).<br></div><div>Programming is fundamentally different from natural languages and thus the similarity on surface doesn't always convey benefits.<br></div><div><br></div><div> </div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">

For a form control, I would much rather see TemperatureScrollBar than scbTemp.</blockquote><div><br></div><div>scbTemp has the same information, but in much more concise way. So, if there are long lines I would strongly prefer "scbTemp", otherwise I don't mind at all.</div><div><br></div><div><br></div><div>Jussi<br></div><br></div></div>