[Gambas-user] [Gambas Bug Tracker] Bug #835: gambas3 doesn't build with llvm > 3.5

bugtracker at ...3416... bugtracker at ...3416...
Sun Nov 8 20:00:40 CET 2015


Comment #5 by Gianfranco COSTAMAGNA:

Hi, the problem is that llvm is hard to maintain, and currently Debian provides
the 3.4, 3.5, 3.6, 3.7 and snapshots versions.

now we are doing a transition to llvm-3.6 as default, and gambas is not building anymore

(I'm planning to force 3.5 in the meanwhile, but it isn't the correct solution in the long term)

Upstream AFAIK doesn't support all of them, and this makes it even harder to maintain specially for LTS Debian releases.

So we are trying to migrate to newer llvm versions, and 3.4 will e.g. disappear soonish (we are currently working on ghc, the last
package that needs llvm-3.4, but for the new ghc releases they will bundle a llvm-style code, to build it internally when needed)
(they use it only for arm* and seems that they are going in this direction, even if I'm not sure it is acceptable for Debian and security)

QT4 AFAIK is not in the deprecation list, but they are removing the webkit support
(this is something that is slowing down the migration to the new gambas3 release)

for sqlite2 I'm not aware of any deprecation ongoing effort, while for gstreamer I'm not sure what do you mean, we recently removed
gstreamer 0.10, as you can see here [1] [2] [3] but I see gambas3 is using already gstreamer 1.0, so I'm not sure what is the successor
of it, but we shouldnt bother too soon :)

[1] https://release.debian.org/transitions/html/gstreamer0.10-rm.html
[2] https://bugs.debian.org/cgi-bin/pkgreport.cgi?tag=gstreamer0.10-removal;users=slomo@...1238...
[3] https://lists.debian.org/debian-devel/2015/05/msg00335.html

More information about the User mailing list