<div dir="ltr"><div dir="ltr"><div class="gmail_default" style="font-size:small"><br></div></div><br><div class="gmail_quote"><div dir="ltr" class="gmail_attr">On Sat, 8 Jan 2022 at 14:41, Rolf-Werner Eilert <<a href="mailto:rwe-sse@osnanet.de">rwe-sse@osnanet.de</a>> wrote:<br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">Am 08.01.22 um 15:32 schrieb Bruce Steers:<br>
> <br>
> <br>
> On Sat, 8 Jan 2022 at 14:26, Rolf-Werner Eilert <<a href="mailto:rwe-sse@osnanet.de" target="_blank">rwe-sse@osnanet.de</a> <br>
> <mailto:<a href="mailto:rwe-sse@osnanet.de" target="_blank">rwe-sse@osnanet.de</a>>> wrote:<br>
> <br>
>     After an update to the latest Gambas version, I still can start SOME of<br>
>     the Gambas applications. The Gambas IDE itself as well as some of the<br>
>     other applications don't start anymore.<br>
> <br>
>     When starting via terminal, I get this:<br>
> <br>
>     $ gambas3<br>
>     Speicherzugriffsfehler (Speicherabzug geschrieben)<br>
> <br>
>     This is under Ubuntu 18 and Mate. Maybe some inconsistency in GTK+?<br>
> <br>
>     I have no chance of going to Ubuntu 20 yet, so should I go back to an<br>
>     older Gambas version? And if so, how would I do this?<br>
> <br>
>     I use the version from the Gambas Team repo I think. It has installed a<br>
>     lot of updates for Gambas, but as the IDE doesn't start, I cannot say<br>
>     what exactly was installed.<br>
> <br>
>     Thanks for your help!<br>
> <br>
>     Rolf<br>
> <br>
> <br>
> to revert the PPA all you can do is go from daily build to stable.<br>
> <br>
> sudo add-apt-repository -r ppa:gambas-team/gambas-daily<br>
> sudo add-apt-repository ppa:gambas-team/gambas3<br>
> <br>
> sudo apt-get upgate<br>
> <br>
> <br>
> <br>
> ----[ <a href="http://gambaswiki.org/wiki/doc/netiquette" rel="noreferrer" target="_blank">http://gambaswiki.org/wiki/doc/netiquette</a> ]----<br>
> <br>
<br>
Hm. I'm pretty sure I am using gambas-team/gambas3:<br>
<br>
apt-get update<br>
OK:1 <a href="http://ppa.launchpad.net/gambas-team/gambas3/ubuntu" rel="noreferrer" target="_blank">http://ppa.launchpad.net/gambas-team/gambas3/ubuntu</a> bionic InRelease<br></blockquote><div><br></div><div style="font-size:small" class="gmail_default">Aah i see,</div><div style="font-size:small" class="gmail_default">hmm, then options would be remove all PPAs and use the default repo version.</div><div style="font-size:small" class="gmail_default">could help track the error. if it still errors on repo version you'll know it's not a gambas bug but a bug in your system.  and if you fix bug then you can upgrade PPA again.</div><div style="font-size:small" class="gmail_default"><br></div><div style="font-size:small" class="gmail_default">BruceS<br></div></div></div>