<html>
  <head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
  </head>
  <body>
    <br>
    <br>
    <div class="moz-cite-prefix">Am 17.09.21 um 10:46 schrieb Bruce
      Steers:<br>
    </div>
    <blockquote type="cite"
cite="mid:CABuQYCDozUKT6BE57bVOAbj99EOkde6v2CaFijQ+piwbc6rsDQ@mail.gmail.com">
      <meta http-equiv="content-type" content="text/html; charset=UTF-8">
      <div dir="ltr">
        <div class="gmail_default" style="font-size:small">When i study
          my form files i see if i have set Public = true then i get the
          following...</div>
        <div class="gmail_default" style="font-size:small"><br>
        </div>
        <div class="gmail_default" style="font-size:small">It adds
          #Public = True to the fields.</div>
        <div class="gmail_default" style="font-size:small">It also adds
          an exclamation mark "!" to the beginning of the definition..</div>
        <div class="gmail_default" style="font-size:small"><br>
        </div>
        <div class="gmail_default" style="font-size:small"><b>      {
            !Button1 Button<br>
                    MoveScaled(5,14,14,4)<br>
                    #Public = True<br>
                    Text = ("WhatRadio?")<br>
                  }</b><br>
        </div>
        <div class="gmail_default" style="font-size:small"><br>
          <br>
        </div>
        <div class="gmail_default" style="font-size:small">Did you try
          adding ! to the definition start?</div>
        <div class="gmail_default" style="font-size:small"><i>Print #fs,
            "{ !" & GSCT & "_" & dat!feld & " TextBox"</i><i><br>
          </i></div>
        <div class="gmail_default" style="font-size:small">BruceS</div>
        <div class="gmail_default" style="font-size:small"><br>
        </div>
        <div class="gmail_default" style="font-size:small"><br>
        </div>
      </div>
      <br>
      <div class="gmail_quote">
        <div dir="ltr" class="gmail_attr">On Thu, 16 Sept 2021 at 12:34,
          Dag Jarle Nerland Johansen - Gambas <<a
            href="mailto:gambas@cd-bahia.com" moz-do-not-send="true">gambas@cd-bahia.com</a>>
          wrote:<br>
        </div>
        <blockquote class="gmail_quote" style="margin:0px 0px 0px
          0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">
          <div> Am 14.09.21 um 13:54 schrieb Dag Jarle Nerland Johansen
            - Gambas:<br>
            <blockquote type="cite"> Hi,<br>
              I generate forms, and set some controls public true,
              because I need the value in other forms. Some fields
              (Textbox) do as they should. I write it out like this,
              same for all fields:<br>
              The data used come as parameter.<br>
              <br>
              <i>      Print #fs, "{   " & GSCT & "_" &
                dat!feld & " TextBox"</i><i><br>
              </i><i>      h = dat!objh / 7</i><i><br>
              </i><i>      Print #fs, "MoveScaled(11, " & Gpy &
                ", " & w & ", " & ma.FLD_H & ")"</i><i><br>
              </i><i>      Print #fs, "Tag=" & ch3 & dat!objtyp
                & ch3</i><i><br>
              </i><i>      Print #fs, "Enabled=" & ch3 &
                dat!enable & ch3</i><i><br>
              </i><i>      Print #FS, "#Public = True"</i><i><br>
              </i><i><br>
              </i><i>      Print #fs, "}"</i><br>
              <br>
              and output is like this:<br>
              <br>
              <i>{   GFLD_tbl TextBox</i><i><br>
              </i><i>MoveScaled(11, 11.3, 21.4285714285714, 3)</i><i><br>
              </i><i>Tag="TB"</i><i><br>
              </i><i>Enabled="-1"</i><i><br>
              </i><i>#Public = True</i><i><br>
              </i><i>}</i><br>
              <br>
              it works fine until I call<br>
              <br>
              <i>  If FMain.GTBL_tbl.Text = "" Then</i><br>
              <br>
              <b>Unknown symbol in FMain.</b> <br>
              I make the field public=false in FMain (IDE), then back to
              true, then it works. another field I use later makes no
              problem, although written the same way. (With  the same
              sub)<br>
              Does anyone have an idea why this only happens with one
              field/control/textbox?<br>
              Thanks in advance<br>
              Dag JNJ<br>
              <br>
              <fieldset></fieldset>
              <pre>----[ <a href="http://gambaswiki.org/wiki/doc/netiquette" target="_blank" moz-do-not-send="true">http://gambaswiki.org/wiki/doc/netiquette</a> ]----
</pre>
            </blockquote>
            Hi again,<br>
            I installed the latest release and hoped the issue was gone,
            but no, still there.<br>
            I got no answers and think I explained it poorly.<br>
            <br>
            I write out .form files, in this case FMain.form<br>
            I need access to some fields from this form, so I made all
            textboxes public.<br>
            The problem that occurs it only with one textbox, named
            GTBL_tbl.<br>
            GTBL_tbl.Public=True, I also see that in the IDE.<br>
            But when I ask if the textbox is empty from another form I
            get the error: Unknown symbol<br>
            I change manually from True to False and back to True - it
            works.<br>
            Following fields that I refer to responds without error,
            that is what confuses me.<br>
            I will search an another solution, though the behaviour is
            not normal.<br>
            Regards, Dag JNJ </div>
          <br>
          ----[ <a href="http://gambaswiki.org/wiki/doc/netiquette"
            rel="noreferrer" target="_blank" moz-do-not-send="true">http://gambaswiki.org/wiki/doc/netiquette</a>
          ]----<br>
        </blockquote>
      </div>
      <br>
      <fieldset class="mimeAttachmentHeader"></fieldset>
      <pre class="moz-quote-pre" wrap="">
----[ <a class="moz-txt-link-freetext" href="http://gambaswiki.org/wiki/doc/netiquette">http://gambaswiki.org/wiki/doc/netiquette</a> ]----
</pre>
    </blockquote>
    Thank you very  much! That little thing was it. You have good eyes,
    or I have bad.<br>
  </body>
</html>