<div dir="ltr"><div class="gmail_default" style="font-size:small">haha, that's mad. (like most political correctness)<br></div><div class="gmail_default" style="font-size:small">Cheers Bruce.<br></div><div class="gmail_default" style="font-size:small"><br></div><div class="gmail_default" style="font-size:small">On linux mint i can't even unset it.</div><div class="gmail_default" style="font-size:small">i even tried chmod -x from terminal , still says it's executable.<br></div><div class="gmail_default" style="font-size:small">when you set  #!/usr/bin/env bash as the first line it becomes an executable automatically.</div><div class="gmail_default" style="font-size:small"><br></div><div class="gmail_default" style="font-size:small">Besides, Personally i think it's the "developer" that wants to decide if the script gets run or viewed. <br></div><div class="gmail_default" style="font-size:small">the "user" doesn't want to see the gubbins ;) they just want the cake not the recipie for the cake ;)<br></div><div class="gmail_default" style="font-size:small"><br></div><div class="gmail_default" style="font-size:small">I'll put it on git , then it should be cool :)<br></div><div class="gmail_default" style="font-size:small">Cheers for the heads up.</div><div class="gmail_default" style="font-size:small">Bruce<br></div></div><br><div class="gmail_quote"><div dir="ltr" class="gmail_attr">On Mon, 12 Oct 2020 at 18:45, Bruce <<a href="mailto:adamnt42@gmail.com">adamnt42@gmail.com</a>> wrote:<br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">On 13/10/20 1:42 am, Bruce Steers wrote:<br>
> Hi all.<br>
> I have written a bash script to help people with cloning / compiling and<br>
> installing gambas3 by hand.<br>
> <a href="http://bws.org.uk/Gambas3-Compile-and-Install.zip" rel="noreferrer" target="_blank">http://bws.org.uk/Gambas3-Compile-and-Install.zip</a><br>
<br>
Hi Bruce S,<br>
<br>
[xxxxxx@xxxxxxxx Downloads]$ lxqt-archiver Gambas3-Compile-and-Install.zip<br>
lxqt-archiver: Exectuable file detected in archive - aborting<br>
[xxxxxx@xxxxxxxx Downloads]<br>
<br>
Political correctness suggests that you don't include executable files <br>
in a zip with the exec flag set. Let the user decide that (whatever it <br>
is) can be executed or not.<br>
<br>
regards<br>
bruce<br>
<br>
----[ <a href="http://gambaswiki.org/wiki/doc/netiquette" rel="noreferrer" target="_blank">http://gambaswiki.org/wiki/doc/netiquette</a> ]----<br>
</blockquote></div>